woocommerce/woocommerce-sniffs

WooCommerce sniffs

Installs: 13 914

Dependents: 3

Suggesters: 0

Stars: 3

Watchers: 6

Forks: 0

Open Issues: 1

Type:phpcodesniffer-standard

0.0.6 2019-03-11 15:30 UTC

README

Collection of PHP_CodeSniffer sniffs for WooCommerce.

Installation

composer require woocommerce/woocommerce-sniffs

Usage

Command line

./vendor/bin/phpcs --standard=WooCommerce-Core <file>

Config file

PHPCS config file:

<?xml version="1.0"?>
<ruleset name="WooCommerce Coding Standards">
    <description>My projects ruleset.</description>
	
    <!-- Configs -->
	<config name="minimum_supported_wp_version" value="4.7" />
	<config name="testVersion" value="5.2-" />

    <!-- Rules -->
    <rule ref="WooCommerce-Core" />

	<rule ref="WordPress.WP.I18n">
		<properties>
			<property name="text_domain" type="array" value="new-text-domain" />
		</properties>
	</rule>

	<rule ref="PHPCompatibility">
		<exclude-pattern>tests/</exclude-pattern>
	</rule>
</ruleset>

Changelog

See changelog for details