vonage/nexmo-bridge

Provides a bridge for using the Vonage PHP SDK with the older Nexmo namespace

0.1.0 2020-08-25 02:50 UTC

This package is not auto-updated.

Last update: 2021-11-27 01:58:49 UTC


README

Build Status MIT licensed codecov

Nexmo is now known as Vonage

This library provides a custom autoloader that aliases legacy Nexmo classes, traits, and interfaces to their replacements under the Vonage namespace.

This library is handy if you want to switch over to the newer vonage/client or vonage/client-core libraries but have a lot of older code that utilizes the \Nexmo namespace. If you are starting a project from scratch, we recommend immediately using the \Vonage namespace.

Much of this code has been ported from the laminas/laminas-zendframework-bridge project.

Installation

Run the following to install this library:

$ composer require vonage/nexmo-bridge

Usage

There is none! By including this package, the autoloader will be automatically invoked and will do all the work for you.

Contributing

This library is actively developed and we love to hear from you! Please feel free to create an issue or open a pull request with your questions, comments, suggestions and feedback.