vast-ru/zf1

This package is abandoned and no longer maintained. The author suggests using the https://github.com/vast-ru/zf1 package instead.

Zend Framework 1

Maintainers

Details

github.com/vast-ru/zf1

Homepage

Source

Installs: 1 004

Dependents: 0

Suggesters: 0

Security: 0

Stars: 0

Watchers: 2

Forks: 729

1.15.0 2020-10-02 07:10 UTC

README

Logo

End-of-Life occurs 28 Sep 2016

Between now and 28 Sep 2016, we will only be accepting security patches to this repository; after that date, we will issue no more releases.

For more information:

Welcome to the Zend Framework 1.12 Release!

Master: Build Status

RELEASE INFORMATION

Zend Framework 1.12.21dev Release. Released on MMM DD, YYYY.

IMPORTANT FIXES FOR 1.12.21

See http://framework.zend.com/changelog for full details.

NEW FEATURES

Zend_Loader changes

A number of autoloaders and autoloader facilities were back ported from ZF2 to provide performant alternatives to those already available in the 1.X releases. These include: Zend_Loader_StandardAutoloader, which improves on Zend_Loader_Autoloader by allowing the ability to specify a specific path to associate with a vendor prefix or namespace; Zend_Loader_ClassMapAutoloader, which provides the ability to use lookup tables for autoloading (which are typically the fastest possible way to autoload); and Zend_Loader_AutoloaderFactory, which can both create and update autoloaders for you, as well as register them with spl_autoload_register().

The Zend_Loader changes were back ported from ZF2 by Matthew Weier O’Phinney

Removed features

Bug Fixes

In addition, over 200 reported issues in the tracker have been fixed. We’d like to particularly thank Adam Lundrigan, Frank Brückner and Martin Hujer for their efforts in making this happen. Thanks also to the many people who ran the ZF1 unit tests and reported their results!

For a complete list of closed issues beginning with 1.12.3, visit:

MIGRATION NOTES

A detailed list of migration notes may be found at:

http://framework.zend.com/manual/en/migration.html

SYSTEM REQUIREMENTS

Zend Framework requires PHP 5.2.11 or later. Please see our reference guide for more detailed system requirements:

http://framework.zend.com/manual/en/requirements.html

INSTALLATION

Please see INSTALL.md.

REPOSITORY HISTORY

This repository was created based on the release-1.12 branch of a Subversion repository, http://framework.zend.com/svn/framework/standard/. It contains a subset of the project history, dating from between the 1.5.0 and 1.6.0 releases, and only contains the tags for the 1.12 series. If you would like an older version, you may access the subversion repository linked above, or download an older version from http://framework.zend.com/downloads/archives.

CONTRIBUTING

Please see README-GIT.md and DEVELOPMENT_README.md.

QUESTIONS AND FEEDBACK

Online documentation can be found at http://framework.zend.com/manual. Questions that are not addressed in the manual should be directed to the appropriate mailing list:

If you find code in this release behaving in an unexpected manner or contrary to its documented behavior, please create an issue in the Zend Framework issue tracker at:

If you would like to be notified of new releases, you can subscribe to the fw-announce mailing list by sending a blank message to:

LICENSE

The files in this archive are released under the Zend Framework license. You can find a copy of this license in LICENSE.txt.

ACKNOWLEDGEMENTS

The Zend Framework team would like to thank all the contributors to the Zend Framework project, our corporate sponsor, and you, the Zend Framework user. Please visit us sometime soon at http://framework.zend.com.