therealgambo/kong-php

A PHP7 compliant library for interacting with the Kong Gateway Admin API.

v0.13.0.1 2018-06-20 06:56 UTC

This package is not auto-updated.

Last update: 2022-01-08 07:49:54 UTC


README

A PHP7 compliant library for interacting with the Kong Gateway Admin API.

Kong Compatibility

Currently supporting Kong >= 0.10.0

Requirements

Installation

Using Composer

To install kong-php with Composer, just add the following to your composer.json file:

{
    "require-dev": {
        "therealgambo/kong-php": "0.10.*"
    }
}

or by running the following command:

composer require therealgambo/kong-php

Usage

PHP

Retrieving Kong node information

$kong = new \TheRealGambo\Kong\Kong(KONG_URL, KONG_PORT);
$node = $kong->getNodeObject();

print_r($node->getInformation());

Retrieving a list of all API's on Kong

$kong = new \TheRealGambo\Kong\Kong(KONG_URL, KONG_PORT);
$apis = $kong->getApiObject();

print_r($apis->list());

Versions

All releases will match for the stable versions of Kong released >= 0.10.0

This ensures stability and resillence within the library reducing any compatibility issues between versions.

License

Kong-php is open-source software and licensed under the MIT License.

Kong is Copyright Mashape, inc.