This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

23andme OAuth2 Provider for Laravel Socialite

4.1.0 2020-12-01 23:10 UTC

This package is auto-updated.

Last update: 2021-09-05 04:17:08 UTC


README

composer require socialiteproviders/twentythreeandme

Installation & Basic Usage

Please see the Base Installation Guide, then follow the provider specific instructions below.

Add configuration to config/services.php

'23andme' => [    
  'client_id' => env('TWENTYTHREEANDME_CLIENT_ID'),  
  'client_secret' => env('TWENTYTHREEANDME_CLIENT_SECRET'),  
  'redirect' => env('TWENTYTHREEANDME_REDIRECT_URI') 
],

Add provider event listener

Configure the package's listener to listen for SocialiteWasCalled events.

Add the event to your listen[] array in app/Providers/EventServiceProvider. See the Base Installation Guide for detailed instructions.

protected $listen = [
    \SocialiteProviders\Manager\SocialiteWasCalled::class => [
        // ... other providers
        'SocialiteProviders\\TwentyThreeAndMe\\TwentyThreeAndMeExtendSocialite@handle',
    ],
];

Usage

You should now be able to use the provider like you would regularly use Socialite (assuming you have the facade installed):

return Socialite::driver('23andme')->redirect();