sle/php-utilities

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

A set of usefull PHP utilities.

v0.9.0 2017-02-20 11:54 UTC

This package is auto-updated.

Last update: 2021-10-14 12:53:27 UTC


README

What does it do?

This library offers a set of usefull PHP utilities.

Requirements

  • PHP 5.5 or heigher

Installation

composer require sle/php-utilities

Base Namespace of this library

Sle\Utilities

List of Utilities

Sle\Utilities

  • DebuggerUtility

Sle\Utilities\DataType

  • ArrayHelper
  • DateUtility
  • StringUtility

Sle\Utilities\Security

  • PasswordCrypt
  • Session

Sle\Utilities\Service

  • CsvService::loadCvsAsAssocArray()
  • CsvService::writeAssocArrayIntoCsvFile()

Sle\Utilities\XSLT

  • XSLTUtility

Sle\Utilities\XML

  • XMLUtility
  • XSDValidator

Sle\Utilities\Google\Maps

  • Geocoding