SAML 1.1 PHP library for SimpleSAMLphp ADFS-module

v1.0.0 2024-03-21 11:34 UTC

This package is auto-updated.

Last update: 2024-05-18 09:49:41 UTC


README

CI Scrutinizer Code Quality Coverage Status PHPStan

A PHP library for SAML 1.1 related functionality.

It is used by the ADFS-module of SimpleSAMLphp.

Before you use it

DO NOT USE THIS LIBRARY UNLESS YOU ARE INTIMATELY FAMILIAR WITH THE SAML 1.1 SPECIFICATION.

If you are not familiar with the SAML 1,1 specification you should probably not use this library.

Usage

  • Install with Composer, run the following command in your project:
composer require simplesamlphp/saml11:^1.0

License

This library is licensed under the LGPL license version 2.1. For more details see LICENSE.