rigor789/airbrake-laravel

Laravel package for the Airbrake API, which supports Errbit

1.3 2019-05-08 15:42 UTC

README

Latest Stable Version Total Downloads Latest Unstable Version License

The master branch is for Laravel 5! For Laravel 4 check out the laravel4 branch.

Versions starting with 0.* are for Laravel 4 Versions starting with 1.* are for Laravel 5

This is a Laravel package for utilizing Airbrake API to collect errors.

It Supports ErrBit just change the host in the config.

Install

First pull in the packages as a dependency

composer require rigor789/airbrake-laravel 

Then add the ServiceProvider to your config/app.php


    ...
    'providers' => [
  
        ...
        'rigor789\AirbrakeLaravel\AirbrakeServiceProvider',
        ...

    ],
    ...
  

Once you have added the ServiceProvider to your app you will need to do some basic configuration. This can be done in your .env file:

AIRBRAKE_ENABLED=true
AIRBRAKE_API_KEY=your_api_key

You can also publish the config file for more advanced configuration options:

php artisan vendor:publish --provider="rigor789\AirbrakeLaravel\AirbrakeServiceProvider"

Then you can enable error reporting also in the config, and customize it as you want. You are good to go!

Issues

If you find any issues, submit a report here

Contributing

If you want to contribute, just submit a pull request.

License

Licensed under the MIT license. See the LICENSE file for details.