rapp-lib/zend-diactoros

Zend Diactoros for PHP 5.3.8-5.3.x. See zendframework/zend-diactoros for PHP 5.4+ support.

1.1.3.1 2017-07-20 11:27 UTC

This package is not auto-updated.

Last update: 2021-05-20 02:20:13 UTC


README

Master: Build status Coverage Status Develop: Build status Coverage Status

Diactoros (pronunciation: /dɪʌktɒrɒs/): an epithet for Hermes, meaning literally, "the messenger."

This package supercedes and replaces phly/http.

zend-diactoros is a PHP package containing implementations of the accepted PSR-7 HTTP message interfaces, as well as a "server" implementation similar to node's http.Server.

Documentation

Documentation is in the doc tree, and can be compiled using bookdown:

$ bookdown doc/bookdown.json
$ php -S 0.0.0.0:8080 -t doc/html/ # then browse to http://localhost:8080/

Bookdown

You can install bookdown globally using composer global require bookdown/bookdown. If you do this, make sure that $HOME/.composer/vendor/bin is on your $PATH.