pk1997/vue

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

vue+laravel laravel5.1 my resume

dev-master 2017-04-11 12:55 UTC

This package is not auto-updated.

Last update: 2021-12-03 06:04:25 UTC


README

composer require pk1997/vue dev-master 引入该包

使用操作

  1. config/app.php 注入服务 加入下面这句话
     Pk\Vue\Providers\VueServiceProvider::class
  1. 生成表
    php artisan migrate --path=vendor/pk1997/vue/database/migrations
  1. database/seed/DatabaseSeeder.php修改文件 run方法里
    $this->call(\Pk\Db\Seeds\ExperienceSeeder::class);
    $this->call(\Pk\Db\Seeds\ResumeSeeder::class);
  1. 填充数据
    php artisan db:seed
  1. 发布公共资源
    php artisan vendor:publish
  1. 安装依赖,打包项目
     1. cd resources/assets
     2. npm install 
     2. webpack
  1. 输入 本地域名/vue 即可看到效果