phpcompatibility/phpcompatibility-joomla

A ruleset for PHP_CodeSniffer to check for PHP cross-version compatibility issues in projects, while accounting for polyfills provided by Joomla.

2.1.1 2019-08-28 14:22 UTC

README

Latest Stable Version Latest Unstable Version License Build Status

PHPCompatibilityJoomla

Using PHPCompatibilityJoomla, you can analyse the codebase of a Joomla-based project for PHP cross-version compatibility.

What's in this repo ?

A ruleset for PHP_CodeSniffer to check for PHP cross-version compatibility issues in projects based on the Joomla CMS.

This Joomla specific ruleset prevents false positives from the PHPCompatibility standard by excluding back-fills and poly-fills which are provided by Joomla.

Requirements

Installation instructions

The only supported installation method is via Composer.

If you don't have a Composer plugin installed to manage the installed_paths setting for PHP_CodeSniffer, run the following from the command-line:

composer require --dev dealerdirect/phpcodesniffer-composer-installer:^0.5.0 phpcompatibility/phpcompatibility-joomla:*
composer install

If you already have a Composer PHP_CodeSniffer plugin installed, run:

composer require --dev phpcompatibility/phpcompatibility-joomla:*
composer install

Next, run:

vendor/bin/phpcs -i

If all went well, you will now see that the PHPCompatibility, PHPCompatibilityJoomla and several other PHPCompatibility standards are installed for PHP_CodeSniffer.

How to use

Now you can use the following command to inspect your code:

./vendor/bin/phpcs -p . --standard=PHPCompatibilityJoomla

By default, you will only receive notifications about deprecated and/or removed PHP features.

To get the most out of the PHPCompatibilityJoomla standard, you should specify a testVersion to check against. That will enable the checks for both deprecated/removed PHP features as well as the detection of code using new PHP features.

The minimum PHP requirement of the Joomla project at this time is PHP 5.3.10. If you want to enforce this, either add --runtime-set testVersion 5.3- to your command-line command or add <config name="testVersion" value="5.3-"/> to your custom ruleset.

For example:

# For a project which should be compatible with PHP 5.3 and higher:
./vendor/bin/phpcs -p . --standard=PHPCompatibilityJoomla --runtime-set testVersion 5.3-

For more detailed information about setting the testVersion, see the README of the generic PHPCompatibility standard.

Testing PHP files only

By default PHP_CodeSniffer will analyse PHP, JavaScript and CSS files. As the PHPCompatibility sniffs only target PHP code, you can make the run slightly faster by telling PHP_CodeSniffer to only check PHP files, like so:

./vendor/bin/phpcs -p . --standard=PHPCompatibilityJoomla --extensions=php --runtime-set testVersion 5.3-

License

All code within the PHPCompatibility organisation is released under the GNU Lesser General Public License (LGPL). For more information, visit https://www.gnu.org/copyleft/lesser.html

Changelog

2.1.1 - 2019-08-29

  • The recommended version of the DealerDirect PHPCS Composer plugin is now ^0.5.0.

2.1.0 - 2018-12-16

  • Ruleset: Updated for the PHP 7.1 polyfill which is included in Joomla 3.9.
  • The ruleset is now also tested against PHP 7.3. Note: full PHP 7.3 support is only available in combination with PHP_CodeSniffer 2.9.2 or 3.3.1+ due to an incompatibility within PHP_CodeSniffer itself.

2.0.0 - 2018-10-07

  • Ruleset: Updated for Joomla 3.9.
  • Ruleset: Updated for compatibility with PHPCompatibility 9.0+.
  • Composer: Added dependencies for the dedicated polyfill-based PHPCompatibility rulesets.
  • CI: Added a test for the ruleset.
  • Readme: Removed the installation instructions for a non-Composer based install.

1.0.0 - 2018-07-17

Initial release of the PHPCompatibilityJoomla ruleset.