php-sword/framework

The PhpSword Framework.

v0.2.5 2022-07-01 06:33 UTC

This package is auto-updated.

Last update: 2022-07-31 06:48:00 UTC


README

   _____                      _  
  / ____|                    | |  PHP      v7.4.21
 | (_____      _____  _ __ __| |  Swoole   v4.7.1
  \___ \ \ /\ / / _ \| '__/ _` |  Temp Dir /www/dev/Temp
  ____) \ V  V | (_) | | | (_| |  Log Dir  /www/dev/Temp/Log
 |_____/ \_/\_/ \___/|_|  \__,_|  Based EasySwoole v3.4.6
 ------------------------v0.1.12------------------------

基于EasySwoole的PHP协程快速开发框架,让你更专注于业务代码的开发

主要特性

  • 采用PHP7强类型(严格模式)
  • 基于Swoole常驻内存
  • 更快速的上手Swoole开发
  • 清晰的项目结构
  • 提供更多便捷的工具

安装

请务必通过 php-sword/sword 构建项目

单独安装

composer require php-sword/framework

参与开发

直接提交PR或者Issue即可

版权信息

本项目遵循Apache2.0 开源协议发布,并提供免费使用。

本项目包含的第三方源码和二进制文件之版权信息另行标注。

更多细节参阅 LICENSE.txt