php-kitchen/code-specs-core

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.
This package is abandoned and no longer maintained. The author suggests using the php-kitchen/code-specs package instead.

Core module of CodeSpecs - BDD extension for PHPUnit and Codeception that allows to write tests as a specifications in a human-readable format.

3.0.1 2017-11-17 15:27 UTC

This package is not auto-updated.

Last update: 2019-02-20 19:19:17 UTC


README

It is a core package for CodeSpecs and it's mirror for Codeception CodeSpecsModule. It's an internal package that gather common code between CodeSpecs and CodeSpecsModule. Do not use this package directly at it supposed to be used only in aforementioned packages.

For docs and guides go to the CodeSpecs project documentation

Package Information

Build status

Build Status Code Quality
Build Status Scrutinizer Code Quality

Versions And Statistics

Latest Stable Version Latest Unstable Version Total Downloads Monthly Downloads Licensing
Latest Stable Version Latest Unstable Version Total Downloads Monthly Downloads License

Requirements

PHP >= 7.1 is required.

PHPUnit >= 6.0 is required but PHPUnit >= 6.2 is recommended.

Contributing

Want to help? First read contributing rules

Then open issue and we would discuss all of the questions about bugfix, feature or request.

Or join our server at Discord if you want to ask any questions, suggest improvements or just to talk with community and developers.