php-extended/php-ip-interface

Interfaces to implement ip (Internet Protocol) v4 and v6 operations.

4.4.1 2022-06-01 06:48 UTC

README

Interfaces to implement ip (Internet Protocol) v4 and v6 operations.

coverage

Installation

The installatipn of this library is made via composer. Download composer.phar from their website. Then add to your composer.json :

	"require": {
		...
		"php-extended/php-ip-interface": "^4",
		...
	}

Then run php composer.phar update to install this library. The autoloading of all classes of this library is made through composer's autoloader.

Basic Usage

This library is an interface-only library.

For a concrete implementatipn, see php-extended/php-ip-object.

License

MIT (See license file).