oxid-esales/twig-component

The component supports twig template engine.

Installs: 1 753

Dependents: 2

Suggesters: 0

Security: 0

Stars: 1

Watchers: 9

Forks: 0

Type:oxideshop-component

v1.0.0 2019-11-21 10:18 UTC

README

Build Status

Includes twig template engine for OXID eShop

Requirements

  • OXID eShop compilation ^v6.2.0

Installation

Usually you don't need to install this component manually as it should be configured as dependency and required by Twig themes that leads to being installed automatically on installing the theme.

To use Twig for templating, you will need some Twig frontend and Twig admin themes installed together, otherwise access to some parts of your shop will not be possible. Current official compatible themes:

Run the following command to install the module manually:

composer require oxid-esales/twig-component

Running tests

To run this module tests, add the tests directory in your test config.yaml file:

    ...    
    run_tests_for_shop: false
    run_tests_for_modules: false
    ...
    additional_test_paths: ./vendor/oxid-esales/twig-component/tests
    ...

and run vendor/bin/runtests

License

See LICENSE file for license details.

Bugs and Issues

If you experience any bugs or issues, please report them in the section OXID eShop (all versions) under category Twig engine of https://bugs.oxid-esales.com