overtrue/laravel-youzan

Youzan wrapper for Laravel.

2.0.1 2018-11-01 03:29 UTC

README

Youzan wrapper for Laravel.

🚧警告!此 SDK 目前仅支持自用型应用,不支持其它类型的应用接入。 由于有赞的不人道的 996 策略,以及在没有通知用户的情况下关闭了个人收款渠道,现决定不再维护他们家任何相关 SDK,谢谢!

Installing

  1. require package.
$ composer require overtrue/laravel-youzan -vvv
  1. config you apps
$ ./artisan vendor:publish 
# select Overtrue\LaravelYouzan\YouzanServiceProvider and enter.

Edit the config/youzan.php with right content.

Usage

  1. Use Facade
# default app
Youzan::post('youzan.shop.create', ['name' => 'Test store']);

# specify app name
Youzan::app('pet-store')->get('youzan.trade.get', ['tid' => 'xxxxxxx']);
  1. Use app() function helper.
# default app
app('youzan')->post('youzan.shop.create', ['name' => 'Test store']);

# specify app name
app('youzan')->app('pet-store')->get('youzan.trade.get', ['tid' => 'xxxxxxx']);

More usage

PHP 扩展包开发

想知道如何从零开始构建 PHP 扩展包?

请关注我的实战课程,我会在此课程中分享一些扩展开发经验 —— 《PHP 扩展包实战教程 - 从入门到发布》

License

MIT