openai-php/symfony

Symfony Bundle for OpenAI

Installs: 100 492

Dependents: 0

Suggesters: 0

Security: 0

Stars: 171

Watchers: 13

Forks: 22

Open Issues: 0

Type:symfony-bundle

v0.8.2 2024-01-15 17:19 UTC

This package is auto-updated.

Last update: 2024-05-16 09:02:48 UTC


README

GitHub Workflow Status (master) Total Downloads Latest Version License

OpenAI PHP for Symfony is a community-maintained PHP API client that allows you to interact with the Open AI API. If you or your business relies on this package, it's important to support the developers who have contributed their time and effort to create and maintain this valuable tool:

Note: This repository contains the integration code of the OpenAI PHP for Symfony. If you want to use the OpenAI PHP client in a framework-agnostic way, take a look at the openai-php/client repository.

Get Started

Requires PHP 8.1+

First, install OpenAI via the Composer package manager:

composer require openai-php/symfony

Next, register the bundle in your config/bundles.php:

return [
    // ...
    OpenAI\Symfony\OpenAIBundle::class => ['all' => true],
]

This will create a .env configuration file in your project, which you can modify to your needs using environment variables:

OPENAI_API_KEY=sk-...
OPENAI_ORGANIZATION=...

Finally, you may use the openai service to access the OpenAI API:

$result = $container->get('openai')->completions()->create([
    'model' => 'gpt-3.5-turbo-instruct',
    'prompt' => 'PHP is',
]);

echo $result['choices'][0]['text']; // an open-source, widely-used, server-side scripting language.

Usage

For usage examples, take a look at the openai-php/client repository.

OpenAI PHP for Symfony is an open-sourced software licensed under the MIT license.