Yii2 component for VK API

Installs: 54

Dependents: 0

Suggesters: 0

Security: 0

Stars: 1

Watchers: 1

Forks: 0

Open Issues: 0

Type:yii2-components

1.0.0 2017-07-06 11:09 UTC

This package is auto-updated.

Last update: 2020-01-19 14:59:50 UTC


README

Russian

Install by composer

composer require oleg-chulakov-studio/yii2-vkapi

Or add this code into require section of your composer.json and then call composer update in console

"oleg-chulakov-studio/yii2-vkapi": "*"

Usage

In configuration file do

<?php
  'components'  =>  [
        'class' => OlegChulakovStudio\YiiVkComponent::className(),
        'clientId' => '',
        'secretCode' => '',
        'accessToken' => '',
        'apiVersion' => '5.67'
  ]
 ?>

Use as simple component

<?php
$responseData = Yii::$app->YiiVk->request('newsfeed.search', [
   'count' => 100,
   'q' => '#tag',
   'extended' => true,
]);
?>