nredbugs/emails

Libreria para la lectura y procesamiento de mensajes de un correo electronico

Installs: 7

Dependents: 0

Suggesters: 0

Security: 0

Stars: 0

Watchers: 1

Forks: 0

Open Issues: 0

Type:package

0.1.01 2016-10-03 17:14 UTC

This package is not auto-updated.

Last update: 2020-09-18 21:18:22 UTC


README

General

Requerimientos

Para la instalación base del paquete emails, asegurese de tener instalada la extensión PHP IMAP

Extensiónes obligatorias

# apt-get install php5-imap

Este paquete extiende de la siguiente librería

# "ddeboer/imap": "^0.5.2"

Es necesario declarar las siguientes variables de entorno

# EMAILS_EMAIL y EMAILS_PASSWORD

en el archivo .env

Documentacion

Instalacion

Para instalar el paquete, solo tiene que agregar

# "nredbugs/emails": "0.1.x-dev"

a su composer.json.A continuación, ejecute composer installo composer update. o puede ejecutar el composer requirecomando desde su terminal:

# composer require nredbugs/emails

Configuracion

$config = array( 
	'hostname' => '', /* Obligatorio ejemplo: imap.gmail.com */
	'port' => '' /* Predeterminado 993 */,
	'flags' => '' /* Predeterminado /imap/ssl/validate-cert */,
	'parameters' => array() ,
);

$email  =  array(
	'processing' => '', /* Obligatorio ejemplo: INBOX (Bandeja principal) */
	'move' => '', /* Ejemplo : [Gmail]/Importantes */
	'path' => '', /* Ruta para almacenar los archivos descargador ejemplo: '/archivos' */
	'extensions' => array() /* Extensiones de archivos a recuperar ejemplo: array('doc','xml','xlxs')*/
);

Solución de problemas