media-store-net/wp-options-manager

A Simple Way to handle with wp_options table in your plugin or theme

1.0.0 2019-09-11 21:55 UTC

README

Description

By developing WordPress Plugins and Themes sometimes you need store your own Project-Settings into the wp_options table. This Tool make it easier to Store and Read options in OOP-environment.

Installation

Easiest way to install is using composer

$ composer require media-store-net/wp-options-manager

you can also add it manually to your composer.json file

"require": {
    "php": ">=5.6.0",
    ...,
    "media-store-net/wp-options-manager": "dev-master"
  },

then use composer update command on your terminal

Minimum Requirements / Dependencies

  • PHP 5.6
  • WordPress latest-2

When installed for development, via Composer requires:

  • phpunit/phpunit (BSD-3-Clause)
  • brain/monkey (MIT)
  • inpsyde/php-coding-standards

Documentation

  1. First Steps
  2. Use in Forms

Licence and Copyright

MIT Licence

Copyright (c) 2019 Media-Store.net