lm-commons/lmc-user-doctrine-odm

Doctrine2 Mongo storage adapter for LmcUser.

1.0.0 2020-06-23 09:36 UTC

This package is auto-updated.

Last update: 2022-01-20 15:07:54 UTC


README

Introduction

LmcUserDoctrineMongoODM is a MongoDb storage adapter for LmcUser. This module makes use of the Doctrine2 MongoDB ODM.

Installation

Composer

  1. Install module
    Go to the release tab and make a note of the most recent version. Run the following command from your application directory: php composer.phar require laminas-commons/lmc-user-doctrine-mongo-odm When asked for er version constraint, put in the version noted from the release tab.

  2. Add DoctrineModule, DoctrineMongoODMModule and LmcUserDoctrineMongoODM to config/application.config.php

Options

The following options are available:

  • enable_default_entities - Boolean value, determines if the default User entity should be enabled. Set it to false in order to extend LmcUser\Entity\User with your own entity. Default is true.

Dependencies