iionly/agerestriction

Force users to verify they are of full age before they are allowed to register.

3.0.0 2019-04-06 14:00 UTC

README

Latest Version: 3.0.0
Released: 2018-08-06
Contact: iionly@gmx.de
License: GNU General Public License version 2
Copyright: (c) iionly 2011

Description

This plugin adds a "confirm age" checkbox on the register form. New users must confirm they are of full age (or any other age range you have in mind - just modify the language file then) before they are allowed to join. There's no verification of any kind if the users really are as old as they say, but at least you have asked them prior registration...

Installation

  1. If you have a previous version of the Agerestriction plugin installed, disable it and then remove the agerestriction folder from your mod directory before copying the new version on the server,
  2. Copy/extract the agerestriction folder/ zip archive into the mod folder,
  3. Enable the Agerestriction plugin.

No guarantee of any kind that it works with any other 3rd party plugins. The age check is currently configured to ask for confirmation of full age (18 years or older). You can change the question by simply modifing language/en.php.