gpupo/common-dev

Common PHP tool for require-dev env

5.3.0 2020-12-08 19:11 UTC

This package is auto-updated.

Last update: 2022-07-24 16:07:30 UTC


README

Common PHP tool for require-dev env

Build Status Actions Status

Requisitos para uso

Este componente não é uma aplicação Stand Alone e seu objetivo é ser utilizado como biblioteca. Sua implantação deve ser feita por desenvolvedores experientes.

Isto não é um Plugin!

As opções que funcionam no modo de comando apenas servem para depuração em modo de desenvolvimento.

A documentação mais importante está nos testes unitários. Se você não consegue ler os testes unitários, eu recomendo que não utilize esta biblioteca.

Direitos autorais e de licença

Este componente está sob a licença MIT

Para a informação dos direitos autorais e de licença você deve ler o arquivo de licença que é distribuído com este código-fonte.

Resumo da licença

Exigido:

  • Aviso de licença e direitos autorais

Permitido:

  • Uso comercial
  • Modificação
  • Distribuição
  • Sublicenciamento

Proibido:

  • Responsabilidade Assegurada

Instalação

Adicione o pacote ao seu projeto utilizando composer:

composer require --dev gpupo/common-dev

Instalação para desenvolvimento

composer install --no-scripts