gordalina/easypay-php

PHP library to communicate with easypay.pt API

Installs: 1 169

Dependents: 1

Stars: 10

Watchers: 6

Forks: 3

Language: PHP

1.0.1 2014-10-13 14:07 UTC

README

Build Status Scrutinizer Quality Score Code Coverage SensioLabs Insight Codacy Badge

This library provides a simple API to communicate with Easypay

Installing via Composer

The recommended way to install is through Composer.

# Install Composer
$ curl -sS https://getcomposer.org/installer | php

# Add easypay-php as a dependency
$ php composer.phar require gordalina/easypay-php:~1.0

After installing, you need to require Composer's autoloader:

require 'vendor/autoload.php';

Testing

This library uses PHPUnit. In order to run the unit tests, you'll first need to install the development dependencies of the project using Composer:

$ php composer.phar install --dev

You can then run the tests using phpunit

$ bin/phpunit

If you want to run integration tests you have to copy phpunit.xml.dist to phpunit.xml then insert your credentials and set EASYPAY_RUN_INTEGRATION_TESTS to true.

Then run phpunit

$ bin/phpunit --exclude-group none

License

This library is under the MIT License, see the complete license here