gelysis/gs4-uniprotect

Simple spam protection module for Silverstripe 4.

Installs: 910

Dependents: 0

Suggesters: 0

Security: 0

Stars: 0

Watchers: 1

Forks: 0

Open Issues: 0

Type:silverstripe-vendormodule

0.9.7-beta 2018-03-01 23:21 UTC

This package is auto-updated.

Last update: 2020-06-29 06:21:24 UTC


README

SilverStripe 4 Uniprotect Form Field Module

Copyright ©2018, Andreas Gerhards andreas@gelysis.net. All rights reserved. / Alle Rechte vorbehalten. / Tous droits réservés.

LICENSE

The Gs4Uniprotect module is open source and licensed as BSD-3-Clause.

Please consult LICENSE.md for further details.

LIZENZ

Das Gs4Uniprotect-Modul ist Open Source und unter der BSD-3-Klausel lizensiert.

Bitte lesen sie LICENSE.md für weitergehende Informationen.

SYSTEM REQUIREMENTS

Requires PHP 5.6 (7.1 recommended) or later.

DESCRIPTION

This package is a optional module for SilverStripe 4. It provides a hidden FormField which allows form to validate for non-bot submissions by checking if the value in that field is correct.

INSTALLATION

  • Use packagist dependency: gelysis/gs4-uniprotect.

USAGE

Standalone Field

If you want to use UniProtect field by itself, you can simply just include it as a field in your form.

$uniprotectField = new Gs4Uniprotect\UniProtectField('MyUniProtect');

Integration with Spamprotection

You can use it to protect any built informs on your website, including user comments in the Blog module. Example for mysite/_config/config.yml:

FormSpamProtectionExtension:
    default_spam_protector: 'UniProtectProtector'

Then once you have setup this config you will need to include the spam protector field as per the instructions on the SpamProtection module page.

QUESTIONS AND FEEDBACK

Please contact the author.

RELEASE INFORMATION

Gs4Uniprotect 0.9.7 2018-03-02

UPDATES

Please see CHANGELOG.md.