fungku/hubspot

HubSpot PHP API client (wrapper for haPiHP)

v1.0.5 2015-10-18 20:25 UTC

This package is not auto-updated.

Last update: 2020-08-07 18:37:38 UTC


README

haPiHP wrapper

Latest Stable Version Total Downloads Scrutinizer Code Quality License

If you want to use the new COS or v2 endpoints, I am writing a completely new api client: https://github.com/fungku/hubspot-php

Setup

In composer.json:

"require": {
	"fungku/hubspot": "1.0.*"
}

then run composer install or composer update

Example

$hapikey = "demo";

$hubspot = new Fungku\HubSpot($hapikey);

// get 5 contacts' firstnames, offset by 50
$contacts = $hubspot->contacts()->get_all_contacts(array(
    'count' => 5, // defaults to 20
    'property' => 'firstname', // only get the specified properties
    'vidOffset' => '50' // contact offset used for paging
));

Note: The Hubspot class checks for a HUBSPOT_APIKEY environment variable if you don't include one during instantiation.

haPiHP

Overview

A PHP client for HubSpot's APIs. Docs for this client: https://github.com/HubSpot/haPiHP/wiki/haPiHP.

General API reference documentation: http://developers.hubspot.com/docs.

Contributors