frenck/php-compatibility

This package is abandoned and no longer maintained. The author suggests using the wimg/php-compatibility package instead.

This is a set of sniffs for PHP_CodeSniffer that checks for PHP version compatibility, composer compatible.

Installs: 16 669

Dependents: 12

Suggesters: 0

Security: 0

Stars: 2

Watchers: 0

Forks: 1

Type:phpcodesniffer-standard

7.1.4 2017-02-24 14:15 UTC

This package is not auto-updated.

Last update: 2018-10-25 10:21:40 UTC


README

This repository is a mirror of the wimg/PHPCompatibility repository.

The wimg/PHPCompatibility has Composer compatibility issues, this repository fixes this, by adding the wimg/PHPCompatibility repository to a sub-directory using git subtree.

This repository only provides a composer.json package file and a update script.

Usage

Using Composer (preferred method):

composer require --dev "frenck/php-compatibility"

Or modify your composer.json to include frenck/php-compatibility in the require-dev sections:

{
  "name": "acme/my-project",
  "require": {
    "": "*"
  },
  "require-dev": {
    "frenck/php-compatibility": "*"
  }
}

The original code is not modified and automatically synced to this mirror every 15 minutes.