dotpulse/outdatedbrowser

Outdated Browser for Neos CMS

Installs: 2 589

Dependents: 0

Suggesters: 0

Security: 0

Stars: 5

Watchers: 3

Forks: 0

Open Issues: 0

Language:HTML

Type:neos-plugin

2.3.2 2020-03-06 13:03 UTC

README

Latest Stable Version Total Downloads License

This package includes Outdated Browser into Neos CMS. You can configure in your Settings.yaml when the warning should be shown.

Version Neos
0.2.* 2.*
> 2.2 3.* + 4.*

Screenshot ot outdatedbrowser.com

Installation

Most of the time you have to make small adjustments to a package (e.g. configuration in Settings.yaml). Because of that, it is important to add the corresponding package to the composer from your theme package. Mostly this is the site packages located under Packages/Sites/. To install it correctly go to your theme package (e.g.Packages/Sites/Foo.Bar) and run following command:

composer require dotpulse/outdatedbrowser --no-update

To install the package under Neos 2.* you have to enter

composer require "dotpulse/outdatedbrowser:~0.2" --no-update

The --no-update command prevent the automatic update of the dependencies. After the package was added to your theme composer.json, go back to the root of the Neos installation and run composer update. Et voilà! Your desired package is now installed correctly.

Configuration

Basicly you need to ajust the setting Dotpulse.OutdatedBrowser.lowerThan. The default value is IE11. You can set the setting Dotpulse.OutdatedBrowser.lowerThan to different kind of values:

  • Browser based
    • A23 (Android 2.3)
    • IE8
    • IE9
    • IE10
    • IE11
    • Edge
  • Feature based
    • Flexbox
    • oldGrid (The old css grid specification)
    • Grid
  • Property based
    • Any CSS property, e. g. transform

Example:

Dotpulse:
  OutdatedBrowser:
    lowerThan: Grid

License

Licensed under MIT, see LICENSE