d3/pdfdocuments_compat

Kompatibilitätslayer für PDF-Dokumentgenerator

1.0.0.0 2020-08-13 07:15 UTC

This package is auto-updated.

Last update: 2020-11-13 08:01:03 UTC


README

english version

PDF-Dokumente - Kompatibilitätsschicht

Kompatibilitätslayer für PDF Dokumente Modul zum OXID InvoicePDF Modul

Diese Anpassung ermöglicht dritten Modulen, die sonst das OXID InvoicePdf-Modul für eigene Zwecke verwenden, anstelle das D3 PDF Dokumente Modul zu verwenden.

Der Generierungsaufruf der Standarddokumente (Rechnung, Lieferschein) wird über das PDF Dokument Modul geroutet.

Wurden weitere Dokumente hinzugefügt, muss das Routing dorthin ergänzt werden.

Das Adminformular zur Dokumentengenerierung wird hierin nicht nachgebaut, da dieses in ähnlicher Form schon im PDF Dokumente Modul enthalten ist. Anpassungen (z.B. Templateblocküberladungen) sollten darauf angepasst werden.

Systemanforderungen:

  • installierter OXID eShop ab Version 6.1
  • D3 PDF Dokumente Modul (wird ggf. nachinstalliert)
  • PHP-Version, für die Installationspakete verfügbar sind (PHP 7)
  • Installation via Composer

Kompatibilität:

Das Modul enthält die selbe Funktionalität wie das OXID Invoice-PDF-Modul. Da es dessen Funktion ersetzen soll, wird das OXID-Modul deinstalliert.

Installation

Deaktivieren Sie das OXID InvoicePDF Modul im Adminbereich Ihres Shops.

composer require d3/pdfdocuments_compat:^1.0 --update-no-dev

Löschen Sie die Dateien des OXID InvoicePDF Moduls.

Support:

Lizenz

Dieses Modul wird unter der GPL v3 Lizenz vertrieben. Für weitere Informationen siehe die ./LICENSE Datei.

Copyright by D3 Data Development (Inh. Thomas Dartsch)