codemascot/wp-flash-message

This is a Composer library package to enhance the usage of WordPress settings API.

1.0.2 2017-11-13 19:29 UTC

README

This is a Composer library package to enhance the usage of WordPress settings API.

Table Of Contents

Coding styles and technique

  • All input data escaped and validated.
  • Developed as Composer package.
  • YODA condition checked.
  • Maintained Right Margin carefully. Usually that is 80 characters.
  • Used true, false and null in stead of TRUE, FALSE and NULL.
  • INDENTATION: TABS has been used in stead of SPACES.
  • PHP Codesniffer checked.
  • WordPress VIP coding standard followed mostly.

Requirements

  • WordPress >= 3.8.0 (Tested)
  • PHP >= 5.6
  • Composer Package Manager

Installation

The best way to use this package is through Composer:

$ composer require codemascot/settings-api

Usage

Checkout the examples folder for OOP and procedural example.

Crafted by Khan

I'm Khan AKA CodeMascot, a professional web developer and I crafted this package for my personal use. Feel free to use this for your projects too.

License

Copyright (c) 2018 Khan M Rashedun-Naby, CodeMascot

Good news, this library is free for everyone! Since it's released under the MIT License you can use it free of charge on your personal or commercial website.

Contribution

All feedback / bug reports / pull requests are welcome.

This package is inspired by wordpress-settings-api-class.