borgenfalkskott/bs-guten-woo

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

Enable gutenberg editor for your Woo products.

Installs: 0

Dependents: 0

Suggesters: 0

Security: 0

Stars: 0

Watchers: 1

Forks: 1

Open Issues: 0

Type:wordpress-muplugin

v0.1.0 2021-08-20 12:35 UTC

This package is auto-updated.

Last update: 2021-09-20 21:58:22 UTC


README

Enable the gutenberg editor for your WooCommerce products.

What does this mu-plugin do?

  • Enabling the Gutenberg editor for your Woo products
  • Disabling ALL tabs on single product page, to give space for gutenberg content
  • Disabling description heading on single product page

Install

Composer

composer require borgenfalkskott/bs-guten-woo

Bedrock

Simply add it to app/mu-plugins/ to have Bedrock autoload it.

Vanilla WordPress

If you are not using Bedrock, simply add an autoloader file in wp-content/mu-plugins/ like this, to have WordPress run this plugin:

// autoloader.php:

<?php
  /**
   * WordPress Mu Plugin Autoloader
   */
  require_once __DIR__ . '/bs-guten-woo/bs-guten-woo.php';
?>

What is a mu-plugin?

Nowadays it stands for "must use plugin", meaning that it is activated automatically by just adding it to the /wp-content/mu-plugins folder.

Single file mu-plugins that sits directly inside the mu-plugins folder, are loaded automatically by WordPress.

For mu-plugins that live inside a subfolder, they need to be autoloaded like the example above or by using something like Bedrock.

Read more about mu-plugins here.

Support our work

⭐️ Star this repo on GitHub.

⭐️ Star this package on Packagist.

❤️ Buy me a coffee.