automattic/jetpack-options

This package is abandoned and no longer maintained. The author suggests using the automattic/jetpack-connection package instead.

A wrapper for wp-options to manage specific Jetpack options.

Installs: 668 297

Dependents: 1

Suggesters: 0

Security: 0

Stars: 3

Watchers: 4

Forks: 2

Type:jetpack-library


README

A static class for Jetpack's options.

Used as a wrapper for WordPress options, allowing folks to add / update / delete options from the Jetpack namespace.

Example Usage

Get a Jetpack option:

Jetpack_Options::get_option( 'version' )

Explore the code for Jetpack_Options to see a complete list of documented methods.

Using this package in your WordPress plugin

If you plan on using this package in your WordPress plugin, we would recommend that you use Jetpack Autoloader as your autoloader. This will allow for maximum interoperability with other plugins that use this package as well.

Security

Need to report a security vulnerability? Go to https://automattic.com/security/ or directly to our security bug bounty site https://hackerone.com/automattic.

License

jetpack-options is licensed under GNU General Public License v2 (or later)