appzcoder/phpcloc

Cloc & duplicate code checker tool.

v0.0.2 2018-05-27 06:27 UTC

This package is not auto-updated.

Last update: 2022-01-22 14:49:39 UTC


README

🚀 Cloc & duplicate code checker written in PHP

Requirements

PHP >= 5.5.9

Installation

Manual

$ wget https://github.com/appzcoder/phpcloc/releases/download/v0.0.2/phpcloc.phar -O phpcloc
// or
$ curl -L https://github.com/appzcoder/phpcloc/releases/download/v0.0.2/phpcloc.phar -o phpcloc

Then

$ sudo chmod a+x phpcloc
$ sudo mv phpcloc /usr/local/bin/phpcloc

Composer

$ composer global require appzcoder/phpcloc

Usage

Cloc

$ phpcloc cloc .

cloc

Duplicate code checker

$ phpcloc duplicate . --ext=php

duplicate

Available Commands

$ phpcloc cloc directory --ext=php,js --exclude=vendor,node_modules
$ phpcloc duplicate directory --ext=php --exclude=vendor

Todo

  • Improve algorithm complexity
  • Testing

Author

Sohel Amin

License

This project is licensed under the MIT License - see the License File for details