adrianmejias/blunder

A PHP library that provides a pretty output for PHP error and exception handling.

dev-main 2021-12-17 18:20 UTC

This package is auto-updated.

Last update: 2022-06-29 08:28:42 UTC


README

security tests StyleCI Build Status codecov Downloads Packagist License Liberapay

A PHP library that provides a pretty output for PHP error and exception handling.

Installation

This version supports PHP 8.0. You can install the package via composer:

composer require --dev adrianmejias/blunder

Example

<?php

require __DIR__ . '/vendor/autoload.php';

use AdrianMejias\Blunder\Blunder;

$blunder = new Blunder();
$blunder->register();

Testing

composer test

Todo

  • Add to packagist repo
  • Add unit tests
  • Add documentation for open source contributations
  • Add GitHub Action for unit tests
  • Add more unit test coverages
  • Add more documentation to README.md
  • Add API listing to README.md

Contributing

Thank you for considering contributing to Veil! You can read the contribution guide here.

Code of Conduct

In order to ensure that the community is welcoming to all, please review and abide by the Code of Conduct.

Security Vulnerabilities

Please see the security file for more information.

License

The MIT License (MIT). Please see the license file for more information.