1032443065/pudge

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

the pudge base on thinkphp framework

Installs: 100

Dependents: 1

Suggesters: 0

Security: 0

Stars: 0

Watchers: 1

Forks: 0

Open Issues: 0

Type:pudge-framework

5.1.12 2017-10-27 03:15 UTC

README

ThinkPHP5.1对底层架构做了进一步的改进,减少依赖,其主要特性包括:

  • 采用容器统一管理对象
  • 支持Facade
  • 更易用的路由
  • 验证类增强
  • 配置和路由目录独立
  • 取消系统常量
  • 类库别名机制
  • 模型和数据库增强
  • 依赖注入完善
  • 支持PSR-3日志规范

废除的功能:

  • 聚合模型
  • 内置控制器扩展类
  • 模型自动验证

ThinkPHP5的运行环境要求PHP5.6以上。

在线手册

命名规范

ThinkPHP5遵循PSR-2命名规范和PSR-4自动加载规范。

参与开发

请参阅 ThinkPHP5 核心框架包

版权信息

ThinkPHP遵循Apache2开源协议发布,并提供免费使用。

本项目包含的第三方源码和二进制文件之版权信息另行标注。

版权所有Copyright © 2006-2017 by ThinkPHP (http://thinkphp.cn)

All rights reserved。

ThinkPHP® 商标和著作权所有者为上海顶想信息科技有限公司。

更多细节参阅 LICENSE.txt