zbateson/gpg-interface

This package is abandoned and no longer maintained. The author suggests using the zbateson/crypt-interface package instead.

Common interface for cryptographic libraries

0.1 2019-03-25 00:48 UTC

This package is auto-updated.

Last update: 2022-03-29 22:37:44 UTC


README

Common interface for cryptographic libraries, created with zbateson/mail-mime-parser in mind.

The interface abstracts five methods, "encrypt", "decrypt", "sign", "verify" and "isSupported".

To include it for use in your project, please install via composer:

composer require zbateson/crypt-interface

Requirements

crypt-interface requires PHP 5.4 or newer.

License

BSD licensed - please see license agreement.