userfrosting/upgrade

Upgrade your database to the latest version of UserFrosting from previous versions of UserFrosting, and other frameworks.

Installs: 67

Dependents: 0

Suggesters: 0

Security: 0

Stars: 1

Watchers: 7

Forks: 1

Open Issues: 0

Type:userfrosting-sprinkle

v4.1.3 2017-12-02 20:19 UTC

This package is auto-updated.

Last update: 2024-03-16 04:11:47 UTC


README

Upgrade your database to UserFrosting 4 from previous versions of UserFrosting, and other frameworks.

Usage

This Sprinkle sets up a fresh installation of UF4 with a pre-existing UF 3.1 database. It will attempt to migrate your users, groups, event log, and custom permissions (authorize_group) to UF4 entities.

Step 1

MAKE A COPY OF YOUR CURRENT DATABASE. This tool does not drop any tables, but it is best to err on the cautious side.

Step 2

Clone the UF4 repo and run composer install, as per the documentation. Manually copy app/sprinkles.example.json to app/sprinkles.json.

Step 3

Edit UserFrosting app/sprinkles.json and add the following to the require list : "userfrosting/upgrade": "~4.1.0". Also add upgrade to the base list. For example:

{
    "require": {
        "userfrosting/upgrade": "~4.1.0"
    },
    "base": [
        "core",
        "account",
        "admin",
        "upgrade"
    ]
}

Step 4 - Update Composer

Run composer update from the root project directory.

Step 5

Run php bakery upgrade from the root project directory. It will prompt you for the credentials for your database - use the credentials for the database you wish to upgrade.

Step 6

Begin migrating your code over to UF 4.1.