tornevall/tornelib-php-plugin-smarty

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

TorneLIB - Generic driver for getting smarty support

6.0.0 2017-10-23 20:18 UTC

This package is not auto-updated.

Last update: 2021-06-05 22:23:06 UTC


README

Why this dual class thing?

Back in the days TorneLIB had its own way to handle templates, inspired by a very old vBulletin release. This code could however never release, since there was a copyright issue in the code of vBulletin. When we got aware of Smarty the old function "evaltemplate" was replaced by the Smarty edition. To maintain the compatibility, Smarty became the default template handler for the global TorneLIB project, which still supported $Library->evaltemplate(); in most of the code.