tomlutzenberger/yii2-smartsupp-chat

Yii2 Widget for Smartsupp Chat

v1.0.0 2019-11-28 09:00 UTC

README

Yii2 Widget for Smartsupp Chat

Installation

The preferred way to install this extension is through composer.

Either run

php composer.phar require --prefer-dist tomlutzenberger/yii2-smartsupp-chat "*"

or add

"tomlutzenberger/yii2-smartsupp-chat": "*"

to the require section of your composer.json file.

Usage

Once the extension is installed, simply use it in your code by:

<?= \TomLutzenberger\Smartsupp\SmartsuppChat::widget() ?>

You can either add the ID of your container to the params.php

<?php
      
return [
    // ...
    'smartsupp' => 'your_key',
];

or pass it directly to the widget:

<?= \TomLutzenberger\Smartsupp\SmartsuppChat::widget([
    'key' => 'your_key'
]) ?>

To be able to use your own triggers you can do this by setting 2 optional parameters:

<?= \TomLutzenberger\Smartsupp\SmartsuppChat::widget([
    'useCustomOpener' => true,
    'useCustomOpenerMobile' => true,
]) ?>

For more details see:

License

This package is published under the MIT License and can be used for any commercial and personal projects.