stevie-mayhew/trait-loader

Adds trait autoloading support to SilverStripe

Installs: 36 258

Dependents: 3

Suggesters: 0

Security: 0

Stars: 2

Watchers: 1

Forks: 7

Type:silverstripe-module

1.0.5 2016-07-27 00:10 UTC

This package is auto-updated.

Last update: 2020-11-16 00:24:59 UTC


README

This module adds in support for autoloading traits to SilverStripe.

Requirements

  • PHP 5.4 or newer
  • SilverStripe 3.1 or newer

Installation

Composer

  • composer require stevie-mayhew/trait-loader
  • Visit http://your-site.com/?flush=1

Manual installation

  • Download an archive and extract into a folder named trait-loader in your site's root folder
  • Visit http://your-site.com/?flush=1

License

This module is licensed under a BSD 3 clause license. See the LICENSE file for the actual license.