soubai/webapplicationsecurity

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

WebSecurity is a PHP class to Help Devlopper to prevent a almost webapplication security fails

0.11a1 2015-12-13 02:51 UTC

This package is not auto-updated.

Last update: 2021-11-27 03:23:17 UTC


README

Description : WebSecurity is a PHP class to Help Devlopper to prevent a almost webapplication security fails:

A - Using Tor OR Proxy to access your webapp;

i) Static Method UsingTor() return bool (if user use Tor Browser = True).

ii) Static Method UsingProxy() return bool (if user use Proxy Service,site,software = True).

B - Prevent :

i) SQL injection : By Using Static Method SQLinj(string) return string.

ii) XSS (Cross Site Scripting) : By Using Static Method XSS(string)return string.

iii) File Inclusion :

a)RFI (Remote File Inclusion) : By Using Static Method RFI(string) return string.

b)LFI (Local File Inclusion) : By Using Static Method LFI(string) return string.

Using this class : install using composer

composer require "soubai/webapplicationsecurity":"0.11a1"

II - create Test.php

III- require "vendor/autoload.php"; in Test.php

VI - WebSecurity::Method //(call class methods eg : UsingTor(), XSS(string), ...)

V - Enjoy