silverstripe/embargoexpiry

This package is abandoned and no longer maintained. No replacement package was suggested.

Adds embargo period and expiry dates to content items. Ripped from advancedworkflow module

Installs: 3 891

Dependents: 0

Suggesters: 0

Security: 0

Stars: 6

Watchers: 6

Forks: 12

Open Issues: 2

Type:silverstripe-module

dev-master 2017-11-28 01:27 UTC

This package is not auto-updated.

Last update: 2019-02-20 18:06:26 UTC


README

THIS MODULE HAS BEEN REPLACED WITH https://github.com/silverstripe-terraformers/silverstripe-embargo-expiry)

This is stripped down version of the AdvancedWorkflow module. It only includes the embargo-expiry features, all other features have been removed from the original code.

Note: This is not compatible with the AdvancedWorkflow module!

Forked from AdvancedWorkflow module (commit: da4efb25984)

Overview

A module that provides embargo and expiry dates for scheduled publishing and unpublishing of content items.

Embargo - allow some content changes to only appear as published at some future date. Expiry - a date-time on which to unpublish some content changes.

Requirements

  • SilverStripe Framework and CMS 3.1 or newer
  • Queued Jobs module (for embargo/expiry functionality)

Installation

Install with composer

composer require silverstripe/embargoexpiry

Then run a dev/build to rebuild your database and class cache

./framework/sake dev/build flush=all

Add WorkflowEmbargoExpiryExtension as a SiteTree extension, in your mysite/_config.yml file.

SiteTree:
    extensions:
        - WorkflowEmbargoExpiryExtension

Ensure the QueuedJobs module is installed and configured correctly. You should have a cronjob similar to the following in place, running as the webserver user.

*/1 * * * * cd  && sudo -u www php /sites/default/www/framework/cli-script.php dev/tasks/ProcessJobQueueTask

Note: you'll need to update the path to cli-script.php to reference your own environment.