quankim/laravel-dynamodb-migrations

There is no license information available for the latest version (2.1) of this package.

Create Migrations (version control) for DynamoDB

2.1 2017-07-10 06:44 UTC

README

Install

  • Composer install
composer require quankim/laravel-dynamodb-migrations
  • Install service provider
// config/app.php
    'providers' => [
        ...
        QuanKim\LaravelDynamoDBMigrations\DynamoDBMigrationServiceProvider::class
        ...
    ];
  • Config DynamoDB
// config/aws.php
    use Aws\Laravel\AwsServiceProvider;
    
    return [
    
        /*
        |--------------------------------------------------------------------------
        | AWS SDK Configuration
        |--------------------------------------------------------------------------
        |
        | The configuration options set in this file will be passed directly to the
        | `Aws\Sdk` object, from which all client objects are created. The minimum
        | required options are declared here, but the full set of possible options
        | are documented at:
        | http://docs.aws.amazon.com/aws-sdk-php/v3/guide/guide/configuration.html
        |
        */
        'credentials' => [
            'key'    => env('AWS_ACCESS_KEY_ID', ''),
            'secret' => env('AWS_SECRET_ACCESS_KEY', ''),
        ],
        'region' => env('AWS_REGION', 'us-east-1'),
        'version' => 'latest',
        'ua_append' => [
            'L5MOD/' . AwsServiceProvider::VERSION,
        ],
        'endpoint' => env('AWS_ENDPOINT', ''),
        'http' => [
            'verify' => false,
        ]
    ];