plinker/lxc

v0.3.8 2018-05-11 16:19 UTC

This package is not auto-updated.

Last update: 2021-11-25 05:25:52 UTC


README

An older/deprecated component which controls LXC1.0 containers.

!!! warning "Development halted" This component is no longer being actively developed, though bugs will be fixed if reported.

This will be replaced by a LXD component which is coming soon!

Install

Require this package with composer using the following command:

$ composer require plinker/lxc

Client

Creating a client instance is done as follows:

<?php
require 'vendor/autoload.php';

/**
 * Initialize plinker client.
 *
 * @param string $server - URL to server listener.
 * @param string $config - server secret, and/or a additional component data
 */
$client = new \Plinker\Core\Client(
    'http://example.com/server.php',
    [
        'secret' => 'a secret password'
    ]
);

// or using global function
$client = plinker_client('http://example.com/server.php', 'a secret password');

Methods

Once setup, you call the class though its namespace to its method.

!!! warning "Undocumented" This component is not documented, methods and usage will be added shortly.

Testing

There are no tests setup for this component.

Contributing

Please see CONTRIBUTING for details.

Security

If you discover any security related issues, please contact me via https://cherone.co.uk instead of using the issue tracker.

Credits

Development Encouragement

If you use this project and make money from it or want to show your appreciation, please feel free to make a donation https://www.paypal.me/lcherone, thanks.

Sponsors

Get your company or name listed throughout the documentation and on each github repository, contact me at https://cherone.co.uk for further details.

License

The MIT License (MIT). Please see License File for more information.

See the organisations page for additional components.