phpmussel/phpmailer

Uses PHPMailer to provide 2FA and email notifications support for phpMussel v3+

v3.1.6 2022-11-20 06:02 UTC

This package is auto-updated.

Last update: 2023-01-09 08:22:49 UTC


README

v1: PHP >= 5.4 v2~v3: PHP >= 7.2 License: GPL v2 PRs Welcome

What is phpMussel?

An ideal solution for shared hosting environments, where it's often not possible to utilise or install conventional anti-virus protection solutions, phpMussel is a PHP script designed to detect trojans, viruses, malware and other threats within files uploaded to your system wherever the script is hooked, based on the signatures of ClamAV and others.

What's this repository for?

This provides a bridge between phpMussel and PHPMailer, enabling phpMussel to utilise PHPMailer for two-factor authentication, email notification about blocked file uploads, etc.

composer require phpmussel/phpmailer

Example:

<?php
// Path to vendor directory.
$Vendor = __DIR__ . DIRECTORY_SEPARATOR . 'vendor';

// Composer's autoloader.
require $Vendor . DIRECTORY_SEPARATOR . 'autoload.php';

$Loader = new \phpMussel\Core\Loader();
$Scanner = new \phpMussel\Core\Scanner($Loader);
$FrontEnd = new \phpMussel\FrontEnd\FrontEnd($Loader, $Scanner);
$Web = new \phpMussel\Web\Web($Loader, $Scanner);
$Loader->Events->addHandler('sendMail', new \phpMussel\PHPMailer\Linker($Loader));

$Web->scan();
$FrontEnd->view();

unset($Web, $FrontEnd, $Scanner, $Loader);

Documentation:

See also:

Last Updated: 1 March 2022 (2022.03.01).