phergie/phergie-irc-plugin-react-thefuckingweather

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.
This package is abandoned and no longer maintained. No replacement package was suggested.

Phergie plugin for providing weather information from thefuckingweather.com

1.0.0 2014-12-27 19:55 UTC

This package is not auto-updated.

Last update: 2020-03-16 04:30:50 UTC


README

This repo is being kept for posterity and will be archived in a readonly state. If you're interested it can be forked under a new Composer namespace/GitHub organization.

phergie/phergie-irc-plugin-react-thefuckingweather

Phergie plugin for providing weather information from thefuckingweather.com.

Build Status

Install

The recommended method of installation is through composer.

composer require phergie/phergie-irc-plugin-react-thefuckingweather

See Phergie documentation for more information on installing and enabling plugins.

Configuration

This plugin has no configuration, but does require the Http plugin.

return array(
    'plugins' => array(
        // dependency
        new \WyriHaximus\Phergie\Plugin\Http\Plugin,

        new \Phergie\Irc\Plugin\React\TheFuckingWeather,
    )
);

Tests

To run the unit test suite:

curl -s https://getcomposer.org/installer | php
php composer.phar install
./vendor/bin/phpunit

License

Released under the BSD License. See LICENSE.