This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.
This package is abandoned and no longer maintained. The author suggests using the paragonie/paseto package instead.

Platform-Agnostic Security Tokens

v2.1.1 2021-09-17 17:07 UTC

This package is auto-updated.

Last update: 2021-09-30 20:36:48 UTC


README

Build Status Latest Stable Version Latest Unstable Version License Downloads

Paseto is everything you love about JOSE (JWT, JWE, JWS) without any of the many design deficits that plague the JOSE standards.

This library is a reference implementation of PASETO in the PHP language. Please refer to the PASETO Specification for design considerations.

How to Use this Library

See the documentation.

The PASETO specification may also be useful for understanding why things are designed the way they are.

Requirements

PHP PASETO Library Version 2

  • Requires PHP 7.1 or newer.
  • For v3 tokens, the GMP and OpenSSL extensions are required.
  • For v4 tokens, the Sodium extension is strongly recommended (but this library will use sodium_compat if it's not).

PHP PASETO Library Version 1

  • Requires PHP 7.0 or newer.
  • For v1 tokens, the OpenSSL extension is required.
  • For v2 tokens, the Sodium extension is strongly recommended (but this library will use sodium_compat if it's not).

Support Contracts

If your company uses this library in their products or services, you may be interested in purchasing a support contract from Paragon Initiative Enterprises.