novusvetus/autogitignore

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

A post-update-cmd script to automatically add Composer managed packages to .gitignore

2.0.0 2021-10-08 21:42 UTC

This package is auto-updated.

Last update: 2021-12-01 09:04:49 UTC


README

Overview

A post-update-cmd script to automatically add Composer managed packages to .gitignore.

Installation

Add the following to your composer.json:

"scripts": {
    "post-update-cmd": "Novusvetus\\AutoGitIgnore\\GitIgnoreBuilder::go"
}

Add it to your project with:

composer require novusvetus/autogitignore

Optional - Exclude only dev packages:

Add to the following to your composer.json

"extra": {
    "autogitignore": "devOnly"
}

License

3-clause BSD license See License

Bugtracker

Bugs are tracked in the issues section of this repository on GitHub. Please read over existing issues before submitting an issue to ensure yours is unique.

Create a new issue

  • Describe the steps to reproduce your issue.
  • Describe the expected and the actual outcome.
  • Describe your environment as detailed as possible.

Development and contribution

Feature requests can also be made by creating a new issue. If you would like to make contributions to this repository, feel free to create a fork and submit a pull request.

Versioning

This project follows Semantic Versioning paradigm. That is:

Given a version number MAJOR.MINOR.PATCH, increment the:

  1. MAJOR version when you make incompatible API changes,
  2. MINOR version when you add functionality in a backwards-compatible manner, and
  3. PATCH version when you make backwards-compatible bug fixes. Additional labels for pre-release and build metadata are available as extensions to the MAJOR.MINOR.PATCH format.

Links

Thanks to