Buckaroo BPE3 API client for PHP. PSR-0 Compliant.

Installs: 3 739

Dependents: 0

Stars: 9

Watchers: 15

Forks: 8

Open Issues: 2

Language: PHP

v1.4 2015-07-11 08:23 UTC


API client for Buckaroo BPE 3.0 for PHP. PSR-0 compliant.


This class is designed to work with the following WSDL:


  • PSR-0 compatible, works with composer and is registered on
  • Supports the TransactionRequests action
  • Handles SOAP WSSEC, SSL thumbprints and signatures using PEM keys
  • Stand-alone library, no external dependencies


Check out composer for details about installing and running composer.

Then, add linkorb/buckaroo to your project's composer.json:

    "require": {
        "linkorb/buckaroo": "1.*"

Try the example

There is a simple example in examples/example.php To make it work,

  • Edit the websiteKey (currently defaults to CHANGEME)
  • Put you private_key.pem file in examples/
  • run php example.php

This will connect to Buckaroo, and send a test transaction. The response of the request will be displayed using var_dump().


Ready to build and improve on this repo? Excellent! Go ahead and fork/clone this repo and we're looking forward to your pull requests! Be sure to update the unit tests in tests/.

If you are unable to implement changes you like yourself, don't hesitate to open a new issue report so that we or others may take care of it.


  • Add unit tests
  • Need test refund, creditnote.
  • Need recurring transaction.


  • Support transaction request, invoiceinfo, refundinfo.


Please check for full license information

Brought to you by the LinkORB Engineering team

Check out our other projects at

Btw, we're hiring!