izisoft/yii2-react

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

The React.js library extension for the Yii framework

Installs: 3

Dependents: 0

Suggesters: 0

Security: 0

Stars: 0

Watchers: 2

Forks: 0

Type:yii2-extension

v0.0.3 2015-05-27 01:06 UTC

This package is not auto-updated.

Last update: 2021-11-24 14:59:00 UTC


README

React.js and JSXTransformer.js Assets

Installation

The preferred way to install this extension is through composer.

Add to the require section of your composer.json file:

composer require --prefer-dist izisoft/yii2-react dev-master
or
"izisoft/yii2-react": "dev-master"

And run in terminal

composer update

If you see the following error message:

Your requirements could not be resolved to an installable set of packages.

Change in the composer.json file

"minimum-stability": "dev",

And add

"prefer-stable": true,

Usage

Add to assets/AppAsset.php file:

'izisoft\react\JSXTransformerAsset', // optional
'izisoft\react\ReactAsset'

For don't use JSXTransformer, use react-tools and add your JSX compiled files in AppAsset.php:

public $js = [
    'build/HelloWorld.js'
];

Further Information

Please, check the React.js site documentation for further information about its configuration options.

Xem thêm các dự án viết bằng yii framework

Kho hàng US - Dịch vụ đặt hàng Mỹ số 1 Việt Nam

Mỹ phẩm cao cấp Hàn Quốc Amaranth - Sorabee - Bello Vita

Chia sẻ kinh nghiệm lập trình php - vps - hosting

Chia sẻ coupon khuyến mãi từ các trang thương mại điện tử hàng đầu tại Việt Nam và trên toàn thế giới

EMZ - Mua gì cũng có

Thao Chip Shop, Chuyên bán buôn, bán lẻ đồ ngủ nữ